Support » Plugin vragen » Contact Form

  • Opgelost stippeltje404

    (@stippeltje404)


    Ik heb sinds kort problemen met de Contact Form plugin
    Ook al heb ik niets veranderd, ik krijg de mail niet meer binnen bij het mailadres wat ik heb opgegeven. Dat mailadres bereik ik dan via Direct Admin, via het programma Round Cube.
    Gelukkig heb ik van Contact Form de tip gekregen om Flamingo te uploaden zodat ik geen enkele mail meer mis, maar ik moet toch simpel bij mijn RoundCube de mail kunnen lezen en beantwoorden?

    Wat ik moeilijk (lees onduidelijk) vind, is hoe het 2e deel van de plugin ingevuld moet worden.
    Wat moet ik invullen bij:
    Mail
    To: ????
    From: ?????
    Uit de Engelstalige versie kan ik dit maar moeilijk opmaken.
    Iemand die mij kan helpen?
    Alvast dank!

11 reacties aan het bekijken - 1 tot 11 (van in totaal 11)
  • Hoi,

    Welk plugin gebruik je voor je contactformulier?

    Kans is aanwezig dat je contact form gebruik maakt van de PHP mailerfunctie van WordPress. Maak gebruik van een SMTP plugin.

    Groeten,
    Bas

    Thread starter stippeltje404

    (@stippeltje404)

    Hey Bas, dank voor je reactie. Ik maak gebruik van Contact Form 7 van Takayuki Miyoshi.
    Ik ga nu op zoek naar een SMTP plugin, kijken of het dan werkt, ik laat het je weten.

    Thread starter stippeltje404

    (@stippeltje404)

    Hmm, ik ben even bezig geweest met Easy WP SMTP, heb gegevens ingevoerd en na een testmail krijg ik dit bericht
    SMTP ERROR: Failed to connect to server: php_network_getaddresses: getaddrinfo failed: Name or service not known (0)SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
    Dus dan is er toch iets met PHP…? Ingewikkeld hoor.
    Ik knutsel nog even door, want dit is voor mij onbekend terrein
    Tips zijn welkom!

    Beste,

    Graag gedaan.

    Onder tab Mail van Contact Form 7:
    In To (Nederlandse vertaling is Aan) vul je het volgende erin: het e-mailadres die je wilt gebruiken om e-mailberichten te ontvangen of gebruik [_site_admin_email]
    In From (Van): [_site_title] <mail@jouwdomeinnaam.domeinextensie>
    In Subject (Onderwerp): Hier vul je je het onderwerp in, bijvoorbeeld e-mail via E-mail formulier of een e-mail-tag
    Additional headings (of headers) vul je in dit veld een e-mail-tag van e-mailadres: Reply-To: Deze e-mail-tag van e-mailadres zie je bovenaan onder het tab Mail die je kan toepassen.

    Voorbeeld: Bij mij is het Reply-To: [E-mailadres].

    In het vak van Bericht Inhoud vul je in samen met de e-mail-tags.

    Deze e-mail-tag van e-mailadres zie je bovenaan onder het tab Mail die je kan toepassen.

    SMTP
    Je hebt de inkomende en uitgaande mailserver nodig (met bij behorende e-mailadres en wachtwoord) om de smtp in te stellen.

    Groeten,
    Bas

    Er is niets met PHP aan de hand.
    Alleen de PHPMailerfunctie kan soms wat problemen veroorzaken met het verzenden en ontvangen van e-mailberichten via contactformulieren, daarom is een SMTP plugin wel aan te raden.

    Wat heb je nodig om SMTP plugin in te stellen:
    * Het e-mailadres
    * Het bijbehorende wachtwoord
    * Inkomende en uitgaande mailserver instellingen (raadpleeg bij je webhoster)

    Groeten,
    Bas

    Thread starter stippeltje404

    (@stippeltje404)

    Dank nogmaals, ik ben de gegevens aan het opvragen en zal daarna alles invullen. Vanavond kom ik er op terug.

    Thread starter stippeltje404

    (@stippeltje404)

    Ik kan het niet laten om het uit te proberen, moet eigenlijk heel wat anders doen.
    Ik heb eerst het contact form 7 opnieuw geïnstalleerd, ingevuld en getest. Resultaat: het komt niet binnen bij Direct Admin, het is gelukkig wel via de plugin Flamingo terug te vinden, maar ik wil dus nog steeds graag een link tussen Contact Form en Direct Admin, oftewel Roundcube webmail.
    Dus ook de Easy WP SMTP geïnstalleerd, geactiveerd en gegevens via de hosting ingevuld. Daarna nog eens het contactformulier ingevuld, maar na verzending komt de mededeling:
    Er is een fout opgetreden bij het versturen van het bericht; probeer het later nog eens.
    Het gekke is dat ik ook deze mail wel bij Flamingo binnen zie komen.
    Wat doe ik toch verkeerd? Ik zie het even niet meer. Eerst maar even weer wat anders doen, misschien kom ik op een idee. Iemand anders?

    Thread starter stippeltje404

    (@stippeltje404)

    Ben ondertussen al een stapje verder, heb hulp van mijn webhoster en het is nu bijna rond!

    Thread starter stippeltje404

    (@stippeltje404)

    Het is nu helemaal opgelost, de webhoster heeft me geholpen met de instellingen en nu werkt alles zoals het moet. Wat dus de precieze oplossing was? Iets met antispamfilter en het juiste mailadres aanmaken. Maar vraag me niet verder, want ik heb het dus niet zelf opgelost 😉

    Thread starter stippeltje404

    (@stippeltje404)

    dus: case closed! Dank Bas, je hebt me op het goede spoor gezet…

    Beste,

    Excuus voor mijn late reactie(s).
    Fijn om te lezen dat het nu is opgelost samen met een meedenkende webhoster.

    Als een spamfilter bijvoorbeeld iets te sterk/hoog ingesteld staat kan het inderdaad false positives veroorzaken: e-mailberichten kunnen worden geweigerd voor aflevering en juiste e-mailadres gebruiken scheelt ook al een hele hoop :-)!

    Ik heb je alleen een zetje gegeven wat de oorzaken kan zijn, en heb jij dit samen met de webhoster opgepakt en opgelost.

    Succes!

    Groeten,
    Bas

11 reacties aan het bekijken - 1 tot 11 (van in totaal 11)