Support » Code oplossingen gezocht » Child theme goes wrong, even with Codex support

  • I hope someone can help me… I’m stuck and can’t continue on a website that was getting somewhere and is now thrown back because my child theme is gone.Trying to re-install a child theme doesn’t work.

    When I do what Codex says, I get this:

    Name Description
    Almasi Child\ The parent theme is missing. Please install the “almasi\” parent theme.

    I had a fine working child theme, until I saw this message below my themes. I hit ‘delete’, which I never should have. I now tried to ftp my child theme and also to upload it through wordpress (zip). None of it works. Even the last time (with the codex based child theme) it said; ‘theme succesfully installed’. However, it’s nowhere to be found…

    This is what I have:

    /*
    Theme Name: Almasi Child
    Theme URI: http://timhupkes.com/almasi-child/
    Description: Almasi Child Theme
    Author: Tim Hupkes
    Author URI: http://timhupkes.com
    Template: almasi
    Version: 1.0.0
    License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    Tags: art, art licensing, painting, fun, illustration, watercolors, humor, office art, character design
    Text Domain: almasi-child
    */

    I had variations on this one, but I’m sure Codex has got it right. Just can’t figure out what went wrong…

    I have put this style.css and the functions.php (a copy of the one from the original theme) in the child file.

    Please help!!!

15 reacties aan het bekijken - 1 tot 15 (van in totaal 29)
  • Moderator Mike

    (@mike_vl)

    Hi tim, tip: check if the almasi theme is written with a capital A.

    Some servers want you to write it exactly as the folder name is written.

    So, if the folder name is Almasi, then they expect Almasi and not almasi.

    Let me know if this helps!

    Thread starter Tim Hupkes

    (@tim983)

    Hoi Mike,

    daar zal ik naar kijken, dank voor je hulp!

    Thread starter Tim Hupkes

    (@tim983)

    Hoi Mike (en anderen),

    Ik heb weer van alles geprobeerd, via ftp en upload, maar het lukt absoluut niet. Ik heb de theme zelf verwijderd en weer geplaatst en toen nog een keer ge-ftp’t en geĆ¼pload. Ik heb zorgvuldig op hoofdletters gelet en variaties van de mogelijke childtheme teksten gebruikt (@import en License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html (niet in hetzelfde style sheet). Als het uiteindelijk lijkt te lukken te uploaden, wordt de child toch niet zichtbaar en krijg ik onderin de themes een melding:

    Broken Themes
    The following themes are installed but incomplete. Themes must have a stylesheet and a template.
    Name Description
    Almasi The parent theme is missing. Please
    Child\ install the “almasi\” parent theme. Delete

    Maar die Almasi theme staat er keurig tussen, is zelfs de geactiveerde… (en hij werkt gewoon: http://www.timhupkes.com) Ik had n.a.v. deze melding de theme dus verwijderd en weer geplaatst, zonder positief resultaat… Ik snap er niets meer van..!

    Ik heb helaas geen idee meer wat ik kan proberen….

    Thread starter Tim Hupkes

    (@tim983)

    Wat voor mij zo onbegrijpelijk is: ik had er een van Almasi. En die werkte… Dus waarom nu niet..? (die vorige heb ik weggedaan door die waarschuwing onderin Themes)

    Thread starter Tim Hupkes

    (@tim983)

    En nu heb ik het helemaal voor elkaar… Op gegeven moment kreeg ik ‘theme install succesful.’ Ik klikte meteen op ‘Activate’. Nu is mijn website aan gort. Ik heb de child in ftp verwijderd. Het maakt niets uit. Ik kan nu niks meer…

    Niks wat ik in ftp probeerde, heeft effect (child theme verwijderen of terugzetten…)

    Waar ik ook op klik in WP, krijg ik dit te zien:

    Warning: include(/home/deb84000/domains/timhupkes.com/public_html/wp-content/themes/almasi-child/inc/almasi-page-showcase.php) [function.include]: failed to open stream: No such file or directory in /home/deb84000/domains/timhupkes.com/public_html/wp-content/themes/almasi-child/functions.php on line 184

    Warning: include() [function.include]: Failed opening ‘/home/deb84000/domains/timhupkes.com/public_html/wp-content/themes/almasi-child/inc/almasi-page-showcase.php’ for inclusion (include_path=’.:/opt/alt/php53/usr/share/pear:/opt/alt/php53/usr/share/php’) in /home/deb84000/domains/timhupkes.com/public_html/wp-content/themes/almasi-child/functions.php on line 184

    Warning: require(/home/deb84000/domains/timhupkes.com/public_html/wp-content/themes/almasi-child/inc/nav-menu-walker.php) [function.require]: failed to open stream: No such file or directory in /home/deb84000/domains/timhupkes.com/public_html/wp-content/themes/almasi-child/functions.php on line 403

    Fatal error: require() [function.require]: Failed opening required ‘/home/deb84000/domains/timhupkes.com/public_html/wp-content/themes/almasi-child/inc/nav-menu-walker.php’ (include_path=’.:/opt/alt/php53/usr/share/pear:/opt/alt/php53/usr/share/php’) in /home/deb84000/domains/timhupkes.com/public_html/wp-content/themes/almasi-child/functions.php on line 403

    Thread starter Tim Hupkes

    (@tim983)

    Pfieuw. Het is gelukt. Vraag me niet hoe (alles uit child in FileZilla verwijderd en alleen style.css laten staan, ik dacht dat functions.php het er ook wel lekker zou doen, vooral ook omdat alleen style.css een hele poos NIET werkte…)

    Nu maar inrichten.

    Ik zal deze post afsluiten.

    Nogmaals bedankt voor alle hulp! šŸ™‚

    Thread starter Tim Hupkes

    (@tim983)

    Sorry voor mijn 4000 berichtjes… ik zeg; het werkt, maar als ik bij themes kijk, staat mijn child er toch niet tussen… Dus helaas, mijn probleem is nog niet opgelost… Ik werk voorlopig maar even in de theme zelf…

    Weet iemand raad?

    Moderator Mike

    (@mike_vl)

    Plak nog eens je child stylesheet.

    Moderator Mike

    (@mike_vl)

    Ok. Maak een map genaamd Tim, plaats daar een style.css met onderstaande code. Deze werkt bij mij icm. almasi thema.

    /*
    Theme Name: Tim
    Theme URI: http://timhupkes.com
    Description: Child theme for Almasi theme
    Author: MvL
    Author URI: http://timhupkes.com
    Template: almasi
    Version: 1.0
    */
    
    @import url("../almasi/style.css");
    Thread starter Tim Hupkes

    (@tim983)

    Hoi Mike,

    hartelijk dank voor je hulp.

    Ik heb een map ‘Tim’ aangemaakt en gecomprimeerd geĆ¼pload. Hij werd niet zichtbaar in themes. Daarna via FileZilla geprobeerd. Ook daarna kreeg ik hem in themes niet te zien. Onderin ‘themes staat nog altijd dezelfde melding:
    Broken Themes

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name Description
    Tim\ The parent theme is missing. Please install the “almasi\” parent theme.

    Almasi verwijderen en weer installeren verhelpt dat niet…

    Moderator Mike

    (@mike_vl)

    Ik heb het even nagebootst:

    Naam Beschrijving
    Tim Er is geen hoofdhema aanwezig. Installeer het hoofdthema “almasii”.

    Zoals je ziet heb ik niet een \ achter de mapnaam en themanaam staan.

    jij wel:

    Name Description
    Tim\ The parent theme is missing. Please install the “almasi\” parent theme.

    Dat is wel apart.

    Thread starter Tim Hupkes

    (@tim983)

    In FileZilla zie ik die backslash ook niet… hoe kan ik die verwijderen..?

    Moderator Mike

    (@mike_vl)

    even een stukje terug: heeft de map almasi bij jou een hoofdletter of niet?

    Kan je een screenshot geven van je ftp map? (gevoelige info verbergen.)

    Thread starter Tim Hupkes

    (@tim983)

    Hoi Mike,

    zo staat hij erin:

    Thread starter Tim Hupkes

    (@tim983)

    Hoi Mike (en anderen),

    Ik heb even een foto gemaakt van de installatie, daar loopt het al spaak zo te zien. Eerst een ‘fail’ (destinatie map bestaat al… !?)

    Nu heb ik hem in FileZilla verwijderd (hij stond IN een andere theme… ) En weer ge-ftp’t, maar nu staat hij niet in Themes (waarnaar ik hem versleept heb) maar…? Kan hem nergens vinden! Niet in een van de andere themes in elk geval. En als ik hem nog een keer upload in themes, zegt FileZilla: ‘vorige file overschrijven?’ Eh… Wat gebeurt hier..? Het lijkt wel een website vortex…

    Ik dacht dat ik de link van die afbeelding van FileZilla al meegestuurd had… niet kennelijk. Dat is: http://www.timhupkes.com/ftp-overzicht/

    En wat ik krijg als ik de zip wil uploaden via wp zelf, is ook op die pagina te zien.

    Wat me wel opvalt: Tim.zip staat nu wel een paar keer in de media bieb..! Dat hoort niet, volgens mij… (foto staat ook op die pagina)

15 reacties aan het bekijken - 1 tot 15 (van in totaal 29)
  • Het onderwerp ‘Child theme goes wrong, even with Codex support’ is gesloten voor nieuwe reacties.