Support » Algemeen WordPress » Categorie in menu werkt niet

  • Opgelost groenehenkie

    (@groenehenkie)


    Ik wil meerdere blogs op mijn website maken. Ik heb begrepen dat dit kan door berichten aan een categorie toe te kennen en die categorie op te nemen in je menu. Lijkt me logisch, dus: even testen. Categorie aanmaken, drie berichtjes maken met verwijzing naar die categorie, categorie in menu opnemen en …… werkt niet. Ik zie alleen maar de naam van de categorie wanneer ik op het desbetreffende menu-item (Gekke Henkie in dit geval) click, maar niet de drie berichten (in geen enkel thema). Wat doe ik mogelijk verkeerd?

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

12 reacties aan het bekijken - 1 tot 12 (van in totaal 12)
  • Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Als ik op de menu items klik zie ik als in de <body> klasses kijk geen archive te zien, dus het is alsof er geen link is naar een categorie ofzo.

    Wat heb je in je permalink structuur staan onder Instellingen > Permalinks? Doe eens gewoon berichtnaam (%postname%) keuze en klik op opslaan. Werkt het daarna?

    Thread starter groenehenkie

    (@groenehenkie)

    Jeroen, dank voor de snelle reactie.

    Instellingen > Permalinks :

    Aangepaste stuctuur – https://degroeneschiedammer.nl /index.php/%year%/%monthnum%/%day%/%postname%/

    Ik heb %postname% aangeklikt en opgeslagen, maar maakt geen verschil (heb het nu weer teruggezet)

    Categoriebasis . (punt)

    Groet, Henk

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Het is moeilijk te zien wat er misgaat, zonder meer toegang te hebben of rond te kunnen kijken op je installatie, vrees ik. (en daar is hier op de forums geen mogelijkheid toe).

    Ik zie gewoon dat de pagina’s niet het archief klasse bevatten, het lijkt een doodnormale pagina in te laden.

    Thread starter groenehenkie

    (@groenehenkie)

    Ik heb begrepen dat er in WordPress pagina’s bestaan en berichten. Wat er onder het menu-item “Gekke Henkie” moet komen, zijn volgens mij berichten. Ik heb dan ook in mijn menu geen pagina opgenomen maar een categorie. Opvallend daarbij is dat er automatisch wordt vermeld “Origineel: Gekke Henkie”. Iets wat ik niet kan wijzigen. Ik heb daarom de pagina “Gekke Henkie” (die had ik ook een keer gemaakt) gedelete en toen kreeg ik als ik op “Gekke Henkie” klikte ineens de berichten te zien, echter, ook alle andere berichten uit andere categorien. En onder de menu-items die ik daarvoor had aangemaakt kreeg ik ze niet te zien. Ik heb daarop alle testberichten gedelete en alle pagina’s die dezelfde naam hadden als de categorien die ik heb aangemaakt. Ik heb nu de volgende categorien:

    Gekke Henkie
    Groene lichten
    Schiedammers
    Schoon genoeg

    Pagina’s met die namen zijn allemaal gedelete. Voor iedere categorie heb ik een overeenkomstig menu-item gemaakt.

    Een eerste testbericht in de categorie “Gekke Henkie” gemaakt met de titel “Op zoek naar de steenrode heidelibel” Gepubliceerd en in mijn menu “Gekke Henkie” aangeklikt. Resultaat:

    Oops! That page can’t be found.

    WordPress heeft het dus duidelijk over een page, terwijl in mijn menu duidelijk staat dat het een categorie is.

    Nog een test-bericht gemaakt getiteld “Op zoek naar de noordse woelmuis”.

    Gepubliceerd en in mijn menu “Gekke Henkie” aangeklikt. Resultaat:

    Oops! That page can’t be found.

    Ik heb in mijn menu ook de berichten-pagina “De groene Schiedammer” opgenomen en daar verschijnen de testberichten wel.

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Alst je spreekt over het verwijderen, heb je ze dan ook permanent verwijderd uit de prullenmand? Zolang die daar zijn, blijft de slug/permalink ingepalmd…

    Thread starter groenehenkie

    (@groenehenkie)

    Goeie tip Jeroen! Prullenmanden (berichten en pagina’s) leeggemaakt, maar …….. ook dat helpt niet.

    Moderator Jeroen Rotty

    (@jeroenrotty)

    Support Moderator

    Ik snap nog niet helemaal waar die origineel: vandaan kan komen … Heb je nog specifiek plugins actief of is dit echt een nieuwe installatie?

    Thread starter groenehenkie

    (@groenehenkie)

    Plugins:

    Askimet Anti-Spam – Niet actief
    Classic Editor – Gedeactiveerd
    Contact Form 7 – Gedeactiveerd
    Elementor – Gedeactiveerd
    Hallo Dolly – Niet actief
    Popularis Extra – Gedeactiveerd
    WordPress Importer – Gedeactiveerd
    WPForms Lite – Gedeactiveerd

    Probleem blijft.

    Guido

    (@guido07111975)

    Hoi Henk,

    Waarom heb je gekozen voor index.php in de permalink? Ik kies altijd “Berichtnaam” (wat Jeroen ook voorstelde). Ook kun je eens testen met de standaard “Eenvoudig”.

    En wat als je een categorie vanuit het dashboard opent? Kom je dan ook op de 404 (Nothing Found) pagina uit?

    Guido

    Thread starter groenehenkie

    (@groenehenkie)

    Guido,

    Dank voor het meedenken.

    Als ik “Berichtnaam” kies als permalink, dan blijft alles zoals het is. Gebruik ik “Eenvoudig” dan kan hij helemaal niks meer vinden. Althans…… terwijl ik dit aan het tikken ben, heb ik nogmaals “Eenvoudig” geprobeerd, en ineens werkt het wel! Een eenoudige oplossing dus (alleen jammer dat ik totaal niet begrijp wat ik nu gedaan heb, maar dat komt nog wel).

    Ik heb de eerste aanwijzing van Jeroen verkeerd begrepen. Ik heb onderaan bij Permalinks op %postname% geklikt en het daarna geprobeerd. Excuus Jeroen! Je bleek me dus de juiste weg te wijzen, maar ik lette niet op.

    Beide dank. Ik ploeter verder!

    Henk

    Guido

    (@guido07111975)

    Hoi,

    Als de standaard permalink wel werkt, maar een andere gangbare zoals “berichtnaam” niet, dan is mogelijk het htaccess bestand niet wijzigbaar en/of heeft je hosting provider een beperking ingesteld. Dus je kunt je hosting provider eens vragen.

    Guido

    Thread starter groenehenkie

    (@groenehenkie)

    tHenks!

12 reacties aan het bekijken - 1 tot 12 (van in totaal 12)