Support » Algemene WordPress vragen » alignwide in ieder block

  • Opgelost rob32

    (@rob32)


    Hoi allemaal,

    Ik word helemaal gestoord. Tot voor kort (<WP5.6) had ik nooit problemen met de tekst&media widget, of kolommen. Alles bleef netjes “tussen de lijntjes” staan.

    Sinds de laatste WP update (naar 5.6) heeft IEDER blok in de blok CSS de parameter “alignwide” meegekregen, waardoor plaatjes en tekst buiten de template gaan. Op mobiele weergave is het helemaal een drama.

    Ik maak mijn sites in Elementor, en ik dacht dat het daar aan lag. Maar ook gewone posts springen op een wijde weergave. Als ik met de code editor de parameter “alignwide” verwijder is het weer prima.

    Waarom gebeurt dit? Iemand een idee? Ik kan er helemaal niets over vinden.

    Codesnippet: <div class=”wp-block-media-text alignwide has-media-on-the-right is-stacked-on-mobile” style=”grid-template-columns:auto 25%”><figure class=”wp-block-media-text__media”></div>

    • Dit onderwerp is gewijzigd 4 weken, 1 dag geleden door rob32.

    De pagina waar ik hulp bij nodig heb: [log in om de link te zien]

4 reacties aan het bekijken - 1 tot 4 (van in totaal 4)
  • Guido

    (@guido07111975)

    Hallo Rob,

    Ik heb hetzelfde probleem. Als ik Media & tekst blok toevoeg komt er standaard een uitlijning bij, maar die kun je dan weer uitvinken. Je ziet in je dashboard niet direct duidelijk dat uitlijning uitgevinkt is, dat merk je pas als je de pagina opslaat en bekijkt in de frontend. Dit is trouwens niet iets van WP 5.6, ik heb daar al langer last van.

    Als je veel van die Media & tekst blokken hebt, zou je ook globaal deze fix kunnen proberen op de Extra CSS pagina in de Customizer:

    
    .alignwide {max-width:100% !important; margin-left:0 !important; margin-right:0 !important;}
    

    Guido

    Thread starter rob32

    (@rob32)

    Guido, man, jij bent een held!
    Hier kan ik op verder. Nu alleen nog wat finetunen, maar het scheelt me echt een partij hoofdpijn!

    I.O.U.!!!

    Guido

    (@guido07111975)

    Graag gedaan!

    Een fix zoals deze is niet de beste oplossing natuurlijk, maar dus wel zo makkelijk als je veel van die blokken hebt.

    Je gebruikt Elementor maar dus ook standaard blokken van WordPress, dat kan een keer fout gaan. Maar gezien Elementor zo’n populaire plugin is mag ik hopen dat er dan snel een fix komt.

    Guido

    Thread starter rob32

    (@rob32)

    Klopt maar het gebeurt niet alleen icm Elementor. Ik zie het met meerdere thema’s ook misgaan; er zal dan ook niets worden gefixt vanuit Elementor.
    Wel is het algemeen te doen gebruikelijk dat men de WP editor gebruikt in Elementor sites voor blogs etc. Daar gaat het niet mis.

    Maar hier ben ik mee geholpen, ziet er allemaal weer strak uit. Nu het volgend probleempje aanpakken (ander issue ingeschoten, ook weer editor).

    Thx Rob

4 reacties aan het bekijken - 1 tot 4 (van in totaal 4)