Ondersteuning » Thema en CSS/opmaak » a/a:hover/a:visited van Theme 12 werkt na wp update niet meer als bedoeld

  • Hoi,
    Merkwaardig probleem bij Theme 12 na wp update 4.7.2:
    Bedoeld is
    a met kleur blauw (#21759b)
    a:hover met kleur donker blauw
    a:visited weer met kleur blauw
    Ik heb daarvoor de css aangepast en werkte prima. Maar na update 4.7.2 werkt het ineens anders. Namelijk na de link te hebben aangeklikt wordt deze grijs en dat blijft ook zo, zelfs een dag later nog. Zoals theme 12 ooit bedoeld is?

    Zie de site Site met grijs na klik op link.
    De site waar het nog wel goed werkt en NIET de update 4.7.2 heb gedaan is Juist werkende site.

    Css aanpassingen:
    /* =Basic structure
    ————————————————————– */

    /* Body, links, basics */
    html {
    font-size: 87.5%;
    }
    body {
    font-size: 14px;
    font-size: 1rem;
    font-family: Helvetica, Arial, sans-serif;
    text-rendering: optimizeLegibility;
    color: #444;
    }
    body.custom-font-enabled {
    font-family: “Open Sans”, Helvetica, Arial, sans-serif;
    }
    a {
    outline: none;
    color: #21759b;
    }
    a:hover {
    color: #0f3647 !important;
    }
    a:visited {
    color: #21759b;
    }

    en

    .entry-content p,
    .entry-summary p,
    .comment-content p,
    .mu_register p {
    margin: 0 0 24px;
    margin: 0 0 1.714285714rem;
    line-height: 1.714285714;
    }
    .entry-content a:visited,
    .comment-content a:visited {
    color: #21759b;
    }

    Wat doe ik fout, mis ik?? Hoop echt dat iemand de tijd voor mij wil nemen. Het zit mij dwars dat het mij niet lukt op te lossen. Ben ver in de 60 en probeer er nog iets van te maken en wil dus niet opgeven, maar er verandert zo veel en je kunt alleen hier nog terecht!

    Groetjes Loek

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Deze `.entry-content a:visited, .comment-content a:visited {
    color: #9f9f9f;
    }` declaratie staat wel in het css van de website waar je het probleem hebt. Alleen zou het deze #21759b kleur moeten zijn.

    Thread starter Loek

    (@loek11)

    Zo stond het er al en desondanks blijft ie grijs.

    .entry-content p,
    .entry-summary p,
    .comment-content p,
    .mu_register p {
    margin: 0 0 24px;
    margin: 0 0 1.714285714rem;
    line-height: 1.714285714;
    }
    .entry-content a:visited,
    .comment-content a:visited {
    color: #21759b;
    }
    .entry-content .more-link {
    white-space: nowrap;
    }

    In ieder geval bedankt voor je snelle reactie
    Loek

    Afbeelding van het css
    Als je kijkt naar het css, blauw gekleurd aan de rechterkant, zie je daar toch echt de waarde #9f9f9f staan. En deze is nu net gemaakt!

    Thread starter Loek

    (@loek11)

    Dit is een goede. Nu kom ik verder.
    1e in mijn style.css komt de kleur #9f9f9f niet voor.
    2e jij ziet het wel
    3e hoe zou dit kunnen en welk programma gebruik jij om dit zichtbaar te krijgen.
    4e zou het iets met de catch te maken kunnen hebben?

    Loek

    • Deze reactie is gewijzigd 5 jaren, 3 maanden geleden door Loek.

    3) http://roosemalen.nl/chrome-inspectie
    4) Dat zou kunnen want ik weet niet hoelang jouw browser in zijn geheugen het uiterlijk van een website moet bewaren.

    Thread starter Loek

    (@loek11)

    Hoi,

    Hoe kan het zijn dat in mijn script, dat op de server van de webhoster staat, de style.css version 2.2 wordt getoond en dat het script dat ik steeds upload de version 2.1 heeft. Daar zit het probleem. Ik werk met 2.1 maar 2.2 wordt ingelezen. Extern?

    Loek

    Nee, dat denk ik niet. Misschien heb jij gewoon het oude css bestand ergens staan terwijl de nieuwe op een andere manier word aangemaakt. Tenminste daar ga ik van uit, dat hij gemaakt word, want waarom staat er anders style.css?ver=4.7.2 Die ?ver=4.7.2 moet toch ergens vandaan komen.

    Thread starter Loek

    (@loek11)

    Opgelost. Ik heb de style.css geupload met chrome en toen pakte ie het wel. Hoe dit kon gebeuren is voor mij een raadsel. Je hebt mij wel goed geholpen om op de mogelijkheden van chrome te wijzen. Wist ik veel?

    Groetjes
    Loek

    Thread starter Loek

    (@loek11)

    Arjan, het kern probleem is dat voor deze site het uploaden van het style.css script niet goed werkt. Ik bedoel dat als ik inlog en normaal aan het script werk en het daarna bevestig, het aangepaste script toch niet opgeslagen wordt, zelfs niet nadat de melding succesvol opgeslagen komt. Althans meestal niet. Dit heb ik niet bij mijn andere sites.

    Hoe dat komt snap ik niet, wel weet ik dat het zich voordoet na de laatste wp update 4.7.2

    Om het op te lossen zou ik het aangepaste scrip met mijn ftp programma ook direct en dus handmatig in de juiste directory kunnen zetten.

    Mijn vraag is of ik dat ongestraft kan doen?

    Groetjes
    Loek

9 reacties aan het bekijken - 1 tot 9 (van in totaal 9)
  • Het onderwerp ‘a/a:hover/a:visited van Theme 12 werkt na wp update niet meer als bedoeld’ is gesloten voor nieuwe reacties.