• Ik heb een wordpress website in aanbouw en wanneer ik de permalinks aanpas naar ‘berichtnaam’ zodat voor de zoekmachines mooi worden weergegeven, dan doen mijn ‘interne’ sitelinks het niet meer. Ik krijg dan continu de melding:

    Error occurred: 404 – not found

    Ik maak gebruik van het Twenty-eleven thema, met wordpress 3.8.1.

    heeft iemand een idee wat de oorzak van deze bug kan zijn en nog beter heeft iemand een oplossing?

4 reacties aan het bekijken - 1 tot 4 (van in totaal 4)
  • NomenNescio

    (@nomennescio)

    En u krijgt geen waarschuwing bij instellingen => permalinks?

    Waarschijnlijk moet u dit invoegen in uw .htaccesbestand:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Thread starter EdMcG

    (@edmcg)

    Wat bedoeld u precies met waarschuwingen ?

    Als ik ga naar Instellingen -> Permalinks -> dan wil ik deze graag instellen op ‘berichtnaam’ zodat deze mooi worden weergegeven. Als ik echter deze instelling selecteer en opsla, dan kan ik op de website geen pagina meer selecteren, want dan krijg ik dus continu de 404 error. Wanneer ik vervolgens de Instellingen -> Permalinks weer aanpas naar ‘Standaard’ en ik daarna weer de website ga bekijken dan werken alle pagina’s wel weer, maar heb ik lelijke permalinks.

    In het verleden heb ik wel vaker in twenty eleven een website gemaakt en altijd de permalinks anders ingesteld, dat leidde nooit tot problemen. Dit is de eerste keer dat ik wordpress 3.8.1. gebruikt heb.

    Waar zou ik volgens u de code moeten invoegen? gelijk in de eerste regels van het .htaccess bestand ?

    NomenNescio

    (@nomennescio)

    Met de waarschuwing bedoel ik een waarschuwing die wordt gegevens als wordt gekozen voor “berichtnaam”.

    Ik kan u vertellen hoe ik het heb aangepakt.
    Als eerste kladblok openen en bovenstaande regels in een document geplakt. Dit document heb ik opgeslagen onder de naam “.htaccess” Vervolgens heb ik dit document met een Ftp-programma geplaatst in de public_html folder. Daarmee was voor mij het probleem opgelost. Ik hoop dat hiermee uw probleem wordt opgelost.

    Thread starter EdMcG

    (@edmcg)

    Dat scriptje is precies hetzelfde als in mijn .htaccess bestand staat….dus ik ben bang dat het toch ergens een conflict is in de de versie van wordpress.

4 reacties aan het bekijken - 1 tot 4 (van in totaal 4)
  • Het onderwerp ‘404 error’ is gesloten voor nieuwe reacties.