YITH WooCommerce Stripe

Omschrijving

Stripe is een WooCommerce uitbereiding die je een betaalwijze toevoegt aan je e-commerce website en je
gebruikers de mogelijkheid geeft om direct met creditcard te betalen via Stripe.com checkout.

Stripe is beschikbaar in de Verenigde Saten, Canada, Verenigd Koningrijk, Australië, België, Frankrijk, Duitsland, Ierland, nederland
en meer – bekijk Welke landen ondersteunen Stripe?

Stripe voordelen:

  • “Proven fraud protection”, stripe werkt actief aan het beschermen van je bedrijf van frauduleuze rekeningen en monitort verdachte transacties.
  • “Act locally, work globally”, werk met internationale klanten per direct, en krijg gewoon betaald in de valuta van je voorkeur.
  • “Operations, simplified’, behandel facturering ondersteuning en diputen gemakkelijk met Stripe – adresseer problemen met enkele klikken of automatiseer het.
  • “Battle-tested systems”, hoge beschikbaarheid, transparante uptime rapportage, en altijd klaar voor een hoge transactie tussendoor.
  • “Seamless security”, Stripe bied veiligheid en diensten zonder hoofdpijn.

Lees de officiële documentatie om alle plugin functies te ontdekken.

Schermafdrukken

  • De betaalwijze op de check-out pagina
  • Betaal pagina
  • Stripe.com Checkout scherm
  • Configuratie

Installatie

  1. Unzip het gedownloade zip bestand.
  2. Upload de plugin map in de wp-content/plugins/ handleiding van je WordPress site.
  3. Activeren YITH WooCommerce Stripe van Plugins pagina

Instellingen

YITH WooCommerce Stripe zal een nieuw tabblad toevoegen genaamd “Stripe”, in Woocommerce -> Settings -> Checkout -> Stripe. Daar kun je alle plugin settings aanpassen.
Je moet jezelf regitreren op Stripe.com en de API Key in de plugin instellingen invoeren.
Je kunt de API Keys vergrkijgen vanaf Je Stripe dashboard.

FAQ

Ondersteunt deze plugin Stripe Checkout?

Ja dat kan! Nadat de gebruiker alle informatie heeft ingevoerd in de check-out pagina, wordt je doorgestuurd naar de betaalpagina waar de Stripe Checkout knop is geplaatst.

Welke landen ondersteunen Stripe?

Stripe is beschikbaar in vele landen en breid zich steeds meer it. Om te zien of jouw land Stripe ondersteunt, bezoek de Stripe Global page.

Is het nodig dat mijn site een SSL certificaat heeft als ik Stripe gebruik?

Ja, het is altijd nodig een SSL certificaat te gebruiken met Stripe. Alle pagina’s die een betaalformulier bevatten moeten prefixed zijn met https://, not http://. See Stripe’s SSL page voor meer informatie.

Beoordelingen

13 september 2019
does not integrate with woocommerce, try and try and the same happend
3 september 2016
Unfortunately doesn't work. After completing payment i am sent to non existing page: /wc-api/YITH_WCStripe_Gateway/?reference=1239&amount=51&signature=2B9813F2AD7886DE58B3DA8313F997A5&stripeToken=tok_184S53CflQUDpAV4xjgUH4Co&stripeTokenType=card&stripeEmail=myemail%40mydomain.dk Will be back at late date to check if it's working, and change my review. Thank you for your effort in making plugins to WordPress and WooCommerce, it is much appreciated.
3 september 2016
Probably the best Stripe plugin 🙂 Highly recommended.
8 februari 2017
this plugin helped me a lot with my customers that don't want to use paypal. A credit cart payment is more confortable for some of those. Thanks to the developer
Lees alle 10 beoordelingen

Bijdragers & ontwikkelaars

“YITH WooCommerce Stripe” is open source software. De volgende personen hebben bijgedragen aan deze plugin.

Bijdragers

“YITH WooCommerce Stripe” is vertaald in 3 talen. Dank voor de vertalers voor hun bijdragen.

Vertaal “YITH WooCommerce Stripe” naar jouw taal.

Interesse in ontwikkeling?

Bekijk de code, haal de SVN repository op, of abonneer je op het ontwikkellog via RSS.

Changelog

2.0.1 – Released on Sep 06, 2019

  • Fix: fout bij aanmaken sessie wanneer gebruiker gast is (dankzij Paul & Maurice)

2.0.0 – Released on Sep 05, 2019

  • Nieuw: Ondersteunt laatste API versie (14-08-2019)
  • Nieuw: Ondersteunt uitsluitend SCA-gereed betaalmethodes
  • Nieuw: ondersteunt nieuwe versie van Stripe Checkout
  • Update: plugin framework 3.0.12
  • Update: Stripe php library naar versie 7.0.0
  • Fix: ongedefinieerde variable err in betaalmethode, fout rapporteer methode.
  • Verwijderd: ondersteuning voor legacy betaalmethode laten vallen (zoals voorgesteld door Stripe)

1.9.3 – Released on Aug 12, 2019

  • Nieuw: Ondersteunt WooCommerce 3.7.0 RC2
  • Update: plugin framework 3.0.12
  • Fix: berekend winkelwagen totaal voor verzenden aan strip, zodat stripe checkout werkt met gift card
  • Dev: methode toegevoegd aan API klasse, om passen te updaten

1.9.2 – Released on Jun 13, 2019

  • Update: plugin framework 3.0.12
  • Dev: nieuw filter yith_wcstripe_charge_params

1.9.1 – Released on Apr 23, 2019

  • Update: plugin framework 3.0.12

1.9.0 – Released on Apr 11, 2019

  • Nieuw: Ondersteunt WooCommerce 3.6
  • Nieuw: controle voor site url toegevoegd, om de testmodus in te stellen wanneer plugin is ingeschakeld in een tijdelijke installatie
  • Tweak: verbeterd fout in melding systeem
  • Update: plugin framework 3.0.12
  • Update: Nederlands taalbestand

1.8.1 – Released on Feb 11, 2019

  • Nieuw: WooCommerce 3.5.4 support
  • Update: plugin framework 3.0.12
  • Update: Stripe php library to version 6.29.3

1.8.0 – Released on Dec 19, 2018

  • Nieuw: WordPress 5,0 ondersteuning
  • Nieuw: WordPress 3.5.2 ondersteuning
  • Nieuw: ondersteuning voor de nieuwste API-versie (2018-11-08)
  • Tweak: controle over configureerbare eigenschappen in update_subscription methode
  • Update: plugin framework 3.0.12
  • Update: Nederlands taalbestand
  • Dev: toegevoegd filter yith_wcstripe_error_message_order_note te laten derde partij code filter foutmeldingen opgeslagen in order Notes

1.7.2 – Released on Oct 24, 2018

  • Nieuw: WooCommerce 3,5 ondersteuning
  • Tweak: bijgewerkt plugin Framework

1.7.1 – Released on Oct 15, 2018

  • Fix: verkeerde links op admin pagina
  • Fix: herstelde plugin panel onder YITH menu
  • Update: Italiaans taalbestand

1.7.0 – Released on Oct 09, 2018

  • Nieuw: ondersteunt WordPress 4.9.8
  • Nieuw: WooCommerce 3,5-RC ondersteuning
  • Nieuw: Updated Stripe API versie 2018-09-24
  • Nieuw: bijgewerkt plug-in-framework
  • Nieuw: toegevoegd pt_PT vertaling (met dank aan Ricardo A.)
  • Tweak: verwijderd create_function voor php 7,2 compatibiliteit
  • Tweak: verwijderd gebruik van afgeschafte WC-functie van Gateway klasse
  • Fix: Ordertotaal bij betaling van order-pay-eindpunt
  • Fix: SSL foutmelding op admin pagina’s
  • Fix: ongeldige streep API-versie
  • Dev: toegevoegd yith_wcstripe_gateway_us_icons filter
  • Dev: toegevoegd yith_wcstripe_gateway_default_icons filter
  • Dev: toegevoegd yith_wcstripe_gateway_icon filter
  • Dev: toegevoegd yith_wcstripe_use_plugin_error_codes filter om originele API foutmeldingen weer te geven
  • Dev: toegevoegd yith_wcstripe_error_message filter te laten derde partij code filter foutmeldingen

1.6.0 – Released on May 28, 2018

  • Nieuw: WooCommerce 3.4.0 ondersteuning
  • Nieuw: WordPress 4.9.6 ondersteuning
  • Nieuw: updated plugin fw
  • Nieuw: GDPR naleven
  • Nieuw: Stripe library 6.7.1 (Noodzakelijk API bijwerken in Stripe Dashboard)
  • Dev: Filter toegevoegd yith_wcstripe_gateway_enabled om de Stripe Gateway via programma code in te schakelen of uit te schakelen
  • Dev: Filter toegevoegd yith_wcstripe_gateway_id om ontwikkelaars gateway ID te filteren (Gebruik deze filter op eigen risico; na het filteren van de gateway ID moet je de gateway opnieuw configureren)

1.5.0 – Released on Feb 08, 2018

  • Nieuw: Ondersteunt WooCommerce 3.3.1
  • Nieuw: ondersteuning voor WordPress 4.9.4
  • Nieuw: geüpdatet Stripe library naar 6.0 revision
  • Nieuw: updated plugin-fw library

1.4.0 – Released on Jan 09, 2018

  • Nieuw: Ondersteunt WooCommerce 3.2.6
  • Nieuw: updated plugin-fw to version 3.0
  • Nieuw: geüpdatet Stripe library naar 5.8 revision
  • Fix: controleer op captured flag op payment_complete
  • Dev: filter toegevoegd yith_wcstripe_environment
  • Dev: filter toegevoegd yith_wcstripe_metadata om derden developers de metadata die wordt verzonden naar Stripe servers te wijzigen

1.3.0 – Released on Apr 04, 04

  • Nieuw – Ondersteunt WordPress 4.7.3
  • Nieuw: Compatibiliteit met WooCommerce 3.0.0-RC2
  • Nieuw: taal toegevoegd – Italiaans
  • Tweak: toegevoegd controle over het bestaan van gateway
  • Nieuw: geüpdatet Stripe library naar 3.23.0
  • Tweak: Tekstdomein gewijzigd naar yith-woocommerce-stripe
  • Dev: filter toegevoegd yith_stripe_locale om de locale gebruikt in check-out te wijzigen

1.2.9 – Released on May 31, 2016

  • Toegevoegd: ondersteunt tot WC 2.6 beta 3

1.2.7.1 – Released on Apr 11, 2016

  • Fixed: vermiste bestanden veroorzaken waarschuwingen

1.2.7 – Released on Apr 06, 2016

  • Fixed: fatale fout met Stripe\Error\API
  • Fixed: foutief winkelwagentotaal op hosted check-out
  • Fixed: interne server out als de import lager is dan .50 cent

1.2.5 – Released on Feb 16, 2016

  • Fixed: stripe library laden veroorzaakt fatale fout in sommige servers

1.2.4 – Released on Jan 19, 2016

  • Nieuw: Compatibiliteit met WooCommerce 2.5
  • Toegevoegd: ondersteunt talen voor “Stripe checkout” modus
  • Update: Stripe API library met laatste versie

1.2.3 – Released on Dec 14, 2015

  • Fixed: geen fouten voor verkeerde kaarten tijdens check-out

1.2.2 – Released on Dec 10, 2015

  • Toegevoegd: compatibiliteit met multi currency plugin

1.2.0 – Released on Aug 12, 2015

  • Toegevoegd: Compatibiliteit met WooCommerce 2.4
  • Updated: Plugin core framework
  • Update: Talenbestand .pot

1.1.0 – Released: Apr 22, 2015

  • Nieuw: Ondersteunt WordPress 4.2

1.0.4 – Released: Apr 21, 2015

  • Updated: talen pot catalogus

1.0.3 – Released: Apr 15, 2015

  • Updated: Stripe API
  • Fix: kleine bugs

1.0.2 – Released: Mar 04, 2015

  • Updated: Plugin core framework

1.0.1 – Released: Mar 03, 2015

  • Fix: kleine bugs

1.0.0

  • Eerste versie