Deze plugin is niet getest met de laatste 3 grotere versies van WordPress. Mogelijk wordt het niet meer onderhouden of ondersteund. Ook kunnen er compatibiliteitsproblemen ontstaan wanneer het wordt gebruikt met recentere versies van WordPress.

WP Post Expires

Beschrijving

A simple plugin that allows to set the date for the posts, after which will be performed one of 3 actions: “Add prefix to title”, “Move to drafts”, “Move to trash”.

Features:

  • Set post expire date and time
  • Support custom post type (post and pages by default)
  • Action for expired posts: move to drafts, move to trash or add custom prefix for title
  • Adds class “post-expired” to post that expired on the site and in admin interface (for custom styles in theme)

Use in theme:

XNPostExpires::isExpired($post_id)

XNPostExpires::dateExpiration($post_id, $date_format)

Schermafdrukken

  • Select date and time in post
  • Add personal prefix for any post
  • Default settings

Installatie

  1. Copy to plugins folder (/wp-content/plugins)

  2. Activate plugin from plugins page in admin interface

  3. Use the Settings->Reading Name screen to configure the plugin

Beoordelingen

8 maart 2021
Update 3/8/21. Not working with 5.6.2. Several issues from earlier support tickets seem to still be unresolved. The time-picker isn't appearing under the calendar picker. Custom Post Types aren't being expired. I notice that support tickets going back one year haven't been answered. Is this plugin being supported?
29 maart 2019
guys, it is working completely fine. I personally tested on 5.1.1 wordpress. read the installation instruction. Thanks team.
23 augustus 2018
Upon first installation, the date picker doesn't work when trying to set the expiry date. Well, that basically renders this plugin useless. Great idea, but needs to work properly first.
19 juli 2018
>>This plugin turns posts to a blank page when set a date to expire. same with me. Any ideas?
Lees alle 14 beoordelingen

Bijdragers & ontwikkelaars

“WP Post Expires” is open source software. De volgende personen hebben bijgedragen aan deze plugin.

Bijdragers

“WP Post Expires” is vertaald in 4 talen. Dank voor de vertalers voor hun bijdragen.

Vertaal “WP Post Expires” naar jouw taal.

Interesse in ontwikkeling?

Bekijk de code, haal de SVN repository op, of abonneer je op het ontwikkellog via RSS.

Changelog

1.2.5

fix bug loop expire. Tnx @d79 (https://github.com/d79)
versiob wp 5.5.3

1.2.4

fix bugs classic editor/gutenberg js, tnx @micahjsharp

1.2.3

add status in post state
change logic for draft and trash, tnx @micahjsharp
use local wp timezone

1.2.2

support classic editor on wp 5.0+

1.2.1

Small fixes:
https://wordpress.org/support/topic/fatal-error-3074/ ( tnx @marknopfler )
https://wordpress.org/support/topic/fix-js-and-php-error/ ( tnx @lastant )

1.2

use DateTime Picker jQuery-ui
refactoring

1.1

conflicts resolved
fix datetime picker
update datetime picker

1.0.3

small fixes
add Italian translation (tnx, Paolo Centomani)

1.0.2

fix notice and accessing static property

1.0.1

fixed translation

1.0

init1 – Mr. Robot