Deze plugin is niet getest met de laatste 3 grotere versies van WordPress. Mogelijk wordt het niet meer onderhouden of ondersteund. Ook kunnen er compatibiliteitsproblemen ontstaan wanneer het wordt gebruikt met recentere versies van WordPress.

Parsedown Party

Omschrijving

This plugin lets you use Markdown for individual posts on a case-by-case basis. Markdown can be activated using a toggle in the post editor submit box. When enabled, it replaces the WordPress post editor with CodeMirror in Markdown mode.

Works on posts using the Classic Editor. Gutenberg is currently not supported.

Schermafdrukken

  • Parsedown Party in the post editor.

FAQ

If I turn this on for a post, can I go back to HTML if I change my mind?

Yes.

Can I automatically enable Markdown for all new posts?

Yes. Add the following line to your theme’s functions.php (or another suitable place):

add_filter( 'parsedownparty_autoenable', '__return_true' );
Is this plugin compatible with Pressbooks?

Yes.

Does this plugin work with Gutenberg?

Not yet. It works on posts using the Classic Editor. The block editor is currently not supported.

I’m a software developer, how can I help?

This plugin follows Pressbooks coding standards and development happens on GitHub.

The philosophy behind this plugin is: Take a best of breed Markdown Parser, combine it with WordPress’ built-in CodeMirror libraries, and let users write posts in Markdown. Things like two-pane WYSIWYG editors are out of scope for this particular plugin (the Preview button works fine.) The design goal is to modify WordPress Core as little as possible while providing decent Markdown support for content.

What about Gutenberg? Haven’t started yet. Tiny MDE looks like a good place to get ideas.

Beoordelingen

Lees 1 beoordeling

Bijdragers & ontwikkelaars

“Parsedown Party” is open source software. De volgende personen hebben bijgedragen aan deze plugin.

Bijdragers

“Parsedown Party” is vertaald in 1 taal. Dank voor de vertalers voor hun bijdragen.

Vertaal “Parsedown Party” naar jouw taal.

Interesse in ontwikkeling?

Bekijk de code, haal de SVN repository op, of abonneer je op het ontwikkellog via RSS.

Changelog

1.2.1

  • Compatibility with WordPress 5.3 (and Classic Editor)
  • Updated composer dependencies

1.2.0

  • Compatibility with WordPress 5.1 (and Classic Editor)
  • Fixed paragraphs following tables

1.1.1

  • Fix cache glitch when previewing.

1.1.0

  • When enabling Markdown on an existing post, convert HTML to Markdown.
  • Cache parsed content using transients.

1.0.2

  • Update Parsedown to version 1.7.1

1.0.1

  • Add parsedownparty_autoenable filter to allow Markdown to be enabled by default.

1.0.0

  • Initial release.