Deze plugin is niet getest met de laatste 3 grotere versies van WordPress. Mogelijk wordt het niet meer onderhouden of ondersteund. Ook kunnen er compatibiliteitsproblemen ontstaan wanneer het wordt gebruikt met recentere versies van WordPress.

Bang Vulnerability Scanner

Omschrijving

This plugin adds an admin page under the Tools section that reports on any known vulnerabilities in your version of WordPress and any installed themes or plugins.

This information is only visible to administrators (or more precisely, those with the manage_options capability). Subscribers, authors and editors cannot see the data.

Source

The information this plugin uses comes from the WPScan Vulnerability Database: https://wpvulndb.com/. It uses a cache and internal throttling to ensure its use of the API is not excessive or abusive.

Note

Using this plugin does not guarantee that your site has no vulnerabilities. It also does not absolve you from responsibilities as a site owner to secure your site in other ways, such as SSL or host security. This plugin is only a tool; using it responsibly is up to you.

WP-CLI

This plugin registers a WP-CLI command, that allows you to scan from the command line. The response codes are compatible with Nagios (1 for critical error, 2 for warning, 3 for unknown).

  • wp vuln scan, to report all known vulnerabilities.
  • wp vuln plugins, to report only vulnerabilities in plugins.
  • wp vuln themes, to report only vulnerabilities in themes.
  • wp vuln wp, to report only vulnerabilities in WordPress core.
  • wp vuln details, to show a more detailed output on known vulnerabilities.
  • wp vuln clear, to clear the internal cache of vulnerability data. This will result in making extra requests to the API, and is probably not needed.

Schermafdrukken

  • The vulnerability scanner shows known vulnerabilities in WordPress, themes and plugins.

Installatie

  1. Upload the whole bang-vulnerability-scanner directory to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Find the vulnerability scanner in the ‘Tools’ menu in WordPress

FAQ

Installation Instructions
  1. Upload the whole bang-vulnerability-scanner directory to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Find the vulnerability scanner in the ‘Tools’ menu in WordPress

Beoordelingen

Er zijn geen beoordelingen voor deze plugin.

Bijdragers & ontwikkelaars

“Bang Vulnerability Scanner” is open source software. De volgende personen hebben bijgedragen aan deze plugin.

Bijdragers

Vertaal “Bang Vulnerability Scanner” naar jouw taal.

Interesse in ontwikkeling?

Bekijk de code, haal de SVN repository op, of abonneer je op het ontwikkellog via RSS.

Changelog

1.0

  • Initial release